Document Title: =============== MyFi Wireless Disk 1.2 iPad iPhone - Multiple Vulnerabilities References (Source): ==================== http://www.vulnerability-lab.com/get_content.php?id=864 Release Date: ============= 2013-02-13 Vulnerability Laboratory ID (VL-ID): ==================================== 864 Common Vulnerability Scoring System: ==================================== 8.3 Product & Service Introduction: =============================== MyFi Wireless-Disk turns your iPhone into a mobile wireless disk - Access your files from any web browser. mobile or desktop. Internet Explorer, Safari, Chrome, Firefox - they are all supported. - Share access to your files with friends. All they need to do is write your iDevice address as it shows in MyFi Wireless-Disk in their browser - Upload new files to your Wireless-Disk from any web browser. - Integration with iTunes file sharing. - Web preview panel to see exactly how others will see your files when opened in browser. - File manager, where you can view and manage your files, no network is required. - Usage graphs for upload and download, storage and users. - Supports landscape and portrait orientation. - Supports iPods, iPhones and iPad. - Supports many file formats in preview, movies, audio, documents and presentations. - Supports multi user access. - No limitation on file size. - No limitation on number of files. (Copy of the Homepage: https://itunes.apple.com/us/app/wireless-disk-free/id558304402) Abstract Advisory Information: ============================== The Vulnerability Laboratory Research Team discovered multiple vulnerabilities in the mobile MyFi Wireless Disk v1.2 app for the apple ipad & iphone. Vulnerability Disclosure Timeline: ================================== 2013-02-13: Public Disclosure Discovery Status: ================= Published Affected Product(s): ==================== Apple AppStore Product: MyFi Wireless Disk 1.2 Exploitation Technique: ======================= Remote Severity Level: =============== Critical Technical Details & Description: ================================ 1.1 A local file include web vulnerability via POST request method is detected in the mobile MyFi Wireless Disk v1.2 app for the apple ipad & iphone. The vulnerability allows remote attackers via POST method to inject local app webserver folders to request unauthorized local webserver files. The vulnerbility is located in the upload file module of the webserver (http://192.168.0.10:80) when processing to upload a file with manipulated `filename` parameter. The execution of the injected path or file request will occur when the attacker is processing to reload to index listing of the affected module. Exploitation of the web vulnerability does not require a privileged application user account (standard) or user interaction. Successful exploitation of the vulnerability results in unauthorized path or file access via local file or path include attack. Vulnerable Application(s): [+] MyFi Wireless Disk v1.2 - ITunes or AppStore (Apple) Vulnerable Module(s): [+] Upload File Vulnerable Parameter(s): [+] filename Affected Module(s): [+] File Dir - Index Listing 1.2 A local command injection web vulnerability is detected in the mobile MyFi Wireless Disk v1.2 app for the apple ipad & iphone. The vulnerability allows to inject local commands via vulnerable system values to compromise the apple mobile application. The vulnerbility is located in the index module when processing to load the ipad or iphone device name. Local attackers can change the ipad or iphone device name to system specific commands and file/path requests to provoke the execution when processing to watch the index listing. Exploitation of the web vulnerability requires a local privileged device user account (standard) without user interaction. Successful exploitation of the vulnerability results unauthorized execution of system specific commands or file/path requests. Vulnerable Application(s): [+] MyFi Wireless Disk v1.2 - ITunes or AppStore (Apple) Vulnerable Module(s): [+] Index Vulnerable Parameter(s): [+] device name - iPad or iPone Affected Module(s): [+] Application Header - Index Listing 1.3 A cross site request forgery web vulnerability is detected in the mobile MyFi Wireless Disk v1.2 app for the apple ipad & iphone. The vulnerability allows remote attackers to form manipulated links or scripts to execute application functions when processing to load client side requests in the web browser. The vulnerability is located in the application delete module and the not secure parsed file parameter. Remote attacker can force application users with not expired session to execute application function when processing to click a manipulated link. Exploitation of the vulnerability requires medium or high user interaction without privileged application user account. Successful exploitation of the vulnerability result in account steal via client side session hijacking, client site phishing, or client-side content request manipulation. Vulnerable Application(s): [+] MyFi Wireless Disk v1.2 - ITunes or AppStore (Apple) Vulnerable Module(s): [+] Delete Vulnerable Module(s): [+] file Affected Module(s): [+] File Dir - Listing Proof of Concept (PoC): ======================= 1.1 The local File/Path Include web vulnerability can be exploited by remote attacker without required application user account (no password: standard) and also without user interaction. For demonstration or reproduce ... Local Path Include Vulnerability PoC: POSTDATA =-----------------------------249872938427813 Content-Disposition: form-data; name="file"; filename="[INJECTED FILE OR PATH REQUEST]<.png" Content-Type: image/png --- ÿØÿà Reference(s): http://192.168.0.10/upload 1.2 The command injection web vulnerability can be exploited by local attackers with required device application user account and with low user interaction. For demonstration or reproduce ... Command Injection via Devicename PoC:
Reference(s): http://192.168.0.10/ 1.3 The client side cross site request forgery web vulnerability can be exploited by remote attackers without application user account and with medium or high required user interaction. For demonstration or reproduce ... POC CSRF - Delete Files Exploit Reference(s): http://192.168.0.10/%3Cdelete%3E http://192.168.0.10/%3Cdelete%3E?file= Security Risk: ============== 1.1 The security risk of the file include web vulnerability is estimated as critical because of no standard password protection. 1.2 The security risk of the local command injection vulnerability via device name is estimated as high(-). 1.3 The security risk of the client side cross site request forgery web vulnerability is estimated as low(+). Credits & Authors: ================== Vulnerability Laboratory [Research Team] - Benjamin Kunz Mejri (bkm@vulnerability-lab.com) Disclaimer & Information: ========================= The information provided in this advisory is provided as it is without any warranty. Vulnerability-Lab disclaims all warranties, either expressed or implied, including the warranties of merchantability and capability for a particular purpose. Vulnerability- Lab or its suppliers are not liable in any case of damage, including direct, indirect, incidental, consequential loss of business profits or special damages, even if Vulnerability-Lab or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply. We do not approve or encourage anybody to break any vendor licenses, policies, deface websites, hack into databases or trade with fraud/stolen material. Domains: www.vulnerability-lab.com - www.vuln-lab.com - www.vulnerability-lab.com/register Contact: admin@vulnerability-lab.com - support@vulnerability-lab.com - research@vulnerability-lab.com Section: video.vulnerability-lab.com - forum.vulnerability-lab.com - news.vulnerability-lab.com Social: twitter.com/#!/vuln_lab - facebook.com/VulnerabilityLab - youtube.com/user/vulnerability0lab Feeds: vulnerability-lab.com/rss/rss.php - vulnerability-lab.com/rss/rss_upcoming.php - vulnerability-lab.com/rss/rss_news.php Any modified copy or reproduction, including partially usages, of this file requires authorization from Vulnerability Laboratory. Permission to electronically redistribute this alert in its unmodified form is granted. All other rights, including the use of other media, are reserved by Vulnerability-Lab Research Team or its suppliers. All pictures, texts, advisories, sourcecode, videos and other information on this website is trademark of vulnerability-lab team & the specific authors or managers. To record, list (feed), modify, use or edit our material contact (admin@vulnerability-lab.com or support@vulnerability-lab.com) to get a permission. Copyright © 2012 | Vulnerability Laboratory