Document Title: =============== Enterpriser16 LB v7.1 - Multiple Web Vulnerabilities References (Source): ==================== http://www.vulnerability-lab.com/get_content.php?id=785 Release Date: ============= 2012-12-11 Vulnerability Laboratory ID (VL-ID): ==================================== 785 Common Vulnerability Scoring System: ==================================== 3.5 Product & Service Introduction: =============================== Load Balancer .org have cemented our reputation as market leaders in affordable server load balancing appliances with the ground-breaking release of firmware v7.0 for the Enterprise product family – which includes a slick new web interface design and many additional features which continue to keep us one step ahead of the competition. (Copy of the Vendor Homepage: http://www.loadbalancer.org ) Abstract Advisory Information: ============================== The Vulnerability Laboratory Research Team discovered multiple web vulnerabilities in Enterpriser16 LoadBalancer v7.1. Vulnerability Disclosure Timeline: ================================== 2012-12-12: Public or Non-Public Disclosure Discovery Status: ================= Published Affected Product(s): ==================== Exploitation Technique: ======================= Remote Severity Level: =============== Medium Technical Details & Description: ================================ Multiple persistent input validation web vulnerabilities are detected in the Enterpriser16 v7.1 Load Balancer Application. The bug allows remote attackers to implement/inject own malicious script code on the application-side (persistent) of the service. The first vulnerabilities are located in the `Edit Configuration` module with the bound vulnerable Label, Virtual Host, Request to send, Email Alerts and Response expected parameters. The second vulnerabilities are located in the Create Solution, Access points and New Contract module with the bound vulnerable title, asset name, contract name, name or description parameter requests. Exploitation requires low user interaction and a low privileged application user account. Successful exploitation of the vulnerability can lead to persistent session hijacking (manager/admin), persistent phishing or persistent module web context manipulation. Vulnerable Module(s): (Edit Configuration) [+] Edit Configuration > layer4 > Virtual Servers [+] Edit Configuration > Layer4 > Real Server [+] Edit Configuration > SSL termination > Modify Vulnerable Parameter(s): [+] [Label] [Virtual Host] [Request to send][Email Alerts][Response expected] [+] [Label] [+] [Label] Vulnerable Module(s): (Admin/Moderator Back-End) [+] Solution > Create Solution [+] Assets > It Assets > Access points [+] Contract > New Contract Vulnerable Parameter(s): [+] [Title] [+] [Asset name] [+] [Contract Name] - [Description] - [Name] - [Support] Proof of Concept (PoC): ======================= The persistent input validation vulnerability can be exploited by remote attackers with low required user interaction & low privileged user account. For demonstration or reproduce ... Review: Edit Configuration > layer4 > Virtual Servers - [Label] [Virtual Host] [Request to send] [Email Alerts] [Response expected]
#0 /var/www/html/lbadmin/inc/ldirectord.inc(695): execute('/etc/rc.d/rc.lv...') #1 /var/www/html/lbadmin/inc/ldirectord.inc(610): 
tcp_timeouts(Array) #2 /var/www/html/lbadmin/config/ldirectord.php(627): ldirectord_vip_edit('0', 'ipv4', '10.1.1.5', '80', '

[PERSISTENT INJECTED SCRIPT CODE!]

', 'tcp', 'masq', '255.255.255.255', '127.0.0.1', '9081', 'yes', '300', 'wrr', 'none', '

[PERSISTENT INJECTED SCRIPT CODE!]

[PERSISTENT INJECTED SCRIPT CODE!]

[PERSISTENT INJECTED SCRIPT CODE!]

[PERSISTENT INJECTED SCRIPT CODE!]

URL: http://loadbalancer.127.0.0.1:8080/lbadmin/config/ldirectord.php?action=modvirtual&subaction=editdata&v=0&t=1355504097 ... Review: Edit Configuration > Add New Floating IP

Error: The Floating IP address '

URL: http://loadbalancer.127.0.0.1:8080/lbadmin/config/changevips.php?mnp=edit&submnp=efip&t=1355527607&l=e ... Review: Edit Configuration > SSL termination > Modify [Label] [Ciphers to use]
execute(): 'cp /usr/local/etc/certs/server.pem /usr/local/etc/certs/

label

.pem' failed: errno 1,

Trace:

#0 /var/www/html/lbadmin/inc/pound.inc(164): execute('cp /usr/local/e...') #1 /var/www/html/lbadmin/config/pound.php(243): pound_vip_add('

[PERSISTENT INJECTED SCRIPT CODE!]

', 'ipv4', '10.0.0.20', '443', '10.0.0.20', '80', '

[PERSISTENT INJECTED SCRIPT CODE!]

URL: http://loadbalancer.127.0.0.1:8080/lbadmin/config/pound.php?action=adddata&t=1355504561 ... Review: Edit Configuration > Physical - Advanced Configuration

Error: Input field failed the validation.
'">