Document Title: =============== Serimux SSH Console Switch 2.4 - Multiple XSS Vulnerabilities References (Source): ==================== https://www.vulnerability-lab.com/get_content.php?id=1942 Release Date: ============= 2016-10-04 Vulnerability Laboratory ID (VL-ID): ==================================== 1942 Common Vulnerability Scoring System: ==================================== 3.4 Product & Service Introduction: =============================== SERIMUX-S-x - The SERIMUX Secure SSH Console Serial Switch delivers secure management of up to 32 serial devices via the internet, TCP/IP network, or dial-up modem connections. It combines the advanced security of Secure Shell v2 with unlimited access to remote network management. (Copy of the Homepage: http://www.networktechinc.com/download/d-srvsw-term-ssh.html ) Abstract Advisory Information: ============================== The vulnerability laboratory core research team discovered multiple cross site vulnerabilities in the Serimux SSH Console Switch v2.4 application. Vulnerability Disclosure Timeline: ================================== 2016-10-04: Public Disclosure (Vulnerability Laboratory) Discovery Status: ================= Published Affected Product(s): ==================== Network Technologies Inc Product: Serimux SSH Console Switch - GUI (Web-Application) 2.4 Exploitation Technique: ======================= Remote Severity Level: =============== Low Technical Details & Description: ================================ Multiple client-side cross site scripting vulnerabilities has been discovered in the Serimux SSH Console Switch v2.4 application. Remote attackers are able to perform malicious client-side request to manipulate browser to web-application requests. The client-side cross site scripting web vulnerabilities are located in the `PAGE`, `SECTION` and `PORTNUMBER` parameters of the `portconnect.asp`, `tcpsettings.asp`,`syslog.asp`,`portcnfiguration.asp` and `systeminfo.asp` files. The affected modules are `./nti/` and ./goform/. The request method to inject is GET and the attack vector is non-persistent. The cross site vulnerabilities allows to perform malicious client-side attacks to compromise user session credentials or affected web-application module context. The security risk of the vulnerabilities are estimated as medium with a cvss (common vulnerability scoring system) count of 3.4. Exploitation of the client-side vulnerabilities requires no privileged web-application user account and only low user interaction. Successful exploitation of the vulnerability results in non-persistent phishing attacks, session hijacking, non-persistent external redirect to malicious sources and non-persistent manipulation of affected or connected web module context. Request Method(s): [+] GET Vulnerable Module(s): [+] ./goform/ [+] ./nti/ Vulnerable File(s): [+] portconnect.asp [+] tcpsettings.asp [+] syslog.asp [+] portconfiguration.asp [+] systeminfo.asp Vulnerable Parameter(s): [+] PAGE [+] PORTNUMBER [+] SECTION Affected Firmware: [+] 2.4 (www.networktechinc.com/download/serimux-ssh-v2-4.tar.gz) [+] 2.3 (www.networktechinc.com/download/serimux-ssh-v2-3.tar.gz) [+] 2.2 (www.networktechinc.com/download/serimux-ssh-v2-2.tar.gz) [+] 2.1 (www.networktechinc.com/download/serimux-ssh-v2-1.tar.gz) Proof of Concept (PoC): ======================= The cross site scripting web vulnerabilities can be exploited by remote attackers without user account and with low user interaction. For security demonstration or to reproduce the security vulnerability follow the provided information and steps below to continue. PoC: Payload(s) >"