Document Title: =============== WpJobBoard v4.5.1 - Multiple Cross Site Web Vulnerabilities References (Source): ==================== https://www.vulnerability-lab.com/get_content.php?id=1941 http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-15375 CVE-ID: ======= CVE-2017-15375 Release Date: ============= 2017-08-18 Vulnerability Laboratory ID (VL-ID): ==================================== 1941 Common Vulnerability Scoring System: ==================================== 3.6 Vulnerability Class: ==================== Cross Site Scripting - Non Persistent Current Estimated Price: ======================== 500€ - 1.000€ Product & Service Introduction: =============================== WPJobBoard is bundled with 15+ shortcodes, allowing you to easily build completely unique job board and insert additional features only when you need it and only where you see fit. WPJobBoard doesn’t limit your website to just a job board. Along with WPJB, you can still maintain a blog and take advantage of all the other features WordPress and its plugins and themes offer. You can keep your community and your blog, but you can add a professional job board. (Copy of the Vendor Homepage: https://wpjobboard.net/features/ ) Abstract Advisory Information: ============================== The vulnerability laboratory core research team discovered multiple client-side cross site web vulnerabilties in the WpJobBoard v4.5.1 web-application for wordpress. Vulnerability Disclosure Timeline: ================================== 2017-08-18: Non-Public Disclosure (Vulnerability Laboratory - Shared Customer Research Feed) Discovery Status: ================= Published Affected Product(s): ==================== WpJobBoard Product: WPJobBoard - Wordpress Plugin (Web-Application) 4.4.4 WpJobBoard Product: WPJobBoard - Wordpress Plugin (Web-Application) 4.5.1 Exploitation Technique: ======================= Remote Severity Level: =============== Medium Technical Details & Description: ================================ Multiple client-side cross site scripting web vulnerabilities has been discovered in the official WpJobBoard v4.5.1 web-application for wordpress. The client-side cross site vulnerability allows remote attackers to inject own malicious script codes to client-side browser to web-application. The vulnerabilities are located in the `query` and `id` parameters of the `wpjb-email`, `wpjb-job`, `wpjb-application` and `wpjb-membership` modules. Remote attackers are able to inject own malicious script code to hijack admin session credentials via backend or to manipulate the backend on client-side performed requests. The attack vector is non-persistent and the request method to inject is GET. The attacker does not need a privileged user account to perform the successful exploitation. The security risk of the client-side cross site scripting vulnerabilities are estimated as medium with a cvss (common vulnerability scoring system) count of 3.6. Exploitation of the client-side cross site scripting web vulnerabilities requires no privileged web-application user account and only low user interaction. Successful exploitation of the vulnerability results in non-persistent phishing attacks, session hijacking, non-persistent external redirect to malicious sources and non-persistent manipulation of affected or connected web module context. Request Method(s): [+] GET Vulnerable Module(s): [+] `wpjb-email` [+] `wpjb-job` [+] `wpjb-application` [+] `wpjb-membership` Vulnerable Parameter(s): [+] query [+] id Affected Module(s): [+] Backend - Administrator & Moderators Proof of Concept (PoC): ======================= The client-side cross site scripting vulnerabilities can be exploited by remote attackers without privileged web-application user account and with low user interaction. For security demonstration or to reproduce the web-application vulnerability follow the provided information and steps below to continue. PoC: Payload >"