Document Title: =============== Easy Cart Shopping Cart - (Search) Persistent Vulnerability Date: ===== 2021-12-15 References: =========== https://www.vulnerability-lab.com/get_content.php?id=2298 VL-ID: ===== 2298 Common Vulnerability Scoring System: ==================================== 5.1 Vulnerability Class: ==================== Cross Site Scripting - Non Persistent Introduction: ============= A mobile-friendly, SEO optimized and easy-to-install (with a free installation also offered also on request) PHP shopping cart script that can be used to add an e-commerce functionality to existing sites or to create simple online stores. Easy Cart is a PHP script allowing to create a simple shopping cart website or integrate a shopping cart functionality in an existing site-the users will be able to browse the products, add them in the cart and check out and make a payment. (Copy of the Homepage: https://www.netartmedia.net/easy-cart ) Abstract: ========= The vulnerability laboratory core research team discovered a cross site scripting web vulnerability in the Easy Cart Shopping Cart PHP Script. Affected Product(s): ==================== NetArt Media Product: Easy Cart Shopping Cart (v2021) - CMS (Web-Application) Report-Timeline: ================ 2021-09-01: Researcher Notification & Coordination (Security Researcher) 2021-09-02: Vendor Notification (Security Department) 2021-**-**: Vendor Response/Feedback (Security Department) 2021-**-**: Vendor Fix/Patch (Service Developer Team) 2021-**-**: Security Acknowledgements (Security Department) 2021-12-15: Public Disclosure (Vulnerability Laboratory) Status: ======== Published Exploitation-Technique: ======================= Remote Severity: ========= Medium Details: ======== A non-persistent post inject web vulnerability has been discovered in the official Easy Cart Shopping Cart PHP Script. The vulnerability allows remote attackers to inject malicious script code in post method requests to compromise user session data or to manipulate application contents for clients. The cross site scripting web vulnerability is located in the `keyword_search` parameter of the `index search` module. Remote attackers without privileged access are able to inject own malicious script code in the search input field of the index module post method request. The execution takes place in the results page of the search after submit via post. Successful exploitation of the vulnerability results in session hijacking, non-persistent phishing attacks, non-persistent external redirects to malicious source and non-persistent manipulation of affected application modules. Request method(s): [+] POST Vulnerable Input(s): [+] Search (index) Vulnerable Parameter(s): [+] keyword_search Proof of Concept: ================= The client-side post inject web vulnerability can be exploited by remote attackers without account and with low or medium user interaction. For security demonstration or to reproduce the cross site web vulnerability follow the provided information and steps below to continue. PoC: Payload >"