Document Title: =============== SuperBackup v2.0.5 - Multiple Site Scripting Vulnerabilities Date: ===== 2020-04-23 References: =========== https://www.vulnerability-lab.com/get_content.php?id=2201 VL-ID: ===== 2201 Common Vulnerability Scoring System: ==================================== 4.3 Vulnerability Class: ==================== Multiple Introduction: ============= Backup all your iPhone or iPad contacts in 1 tap and export them. Fastest way to restore contacts from PC or Mac. Export by mailing the backed up contacts file to yourself. Export contacts file to any other app on your device. Export all contacts directly to your PC / Mac over Wifi, no software needed! Restore any contacts directly from PC / Mac. Restore contacts via mail. Get the ultimate contacts backup app now. (Copy of the Homepage: https://apps.apple.com/us/app/super-backup-export-import/id1052684097 ) Abstract: ========= The vulnerability laboratory core research team discovered multiple non-persistent cross site web vulnerabilities in the official SuperBackup v2.0.5 ios mobile application. Affected Product(s): ==================== Dropouts Technologies LLP Product: Super Backup v2.0.5 Report-Timeline: ================ 2020-04-23: Public Disclosure (Vulnerability Laboratory) Status: ======== Published Exploitation-Technique: ======================= Remote Severity: ========= Medium Details: ======== Multiple cross site scripting web vulnerabilities has been discovered in the official SuperBackup v2.0.5 ios mobile application. The vulnerability allows remote attackers to inject own malicious script codes with non-persistent attack vector to compromise browser to web-application requests from the client-side. The product is publicly certified by the BSI in germany and owns a security policy against backdoors. The cross site scripting vulnerabilities are located in the path parameter of the list and download module. Remote attackers are able to inject own malicious non-persistent script code to client-side requests. The request method to inject is GET and the attack vector is located on the client-side. Attackers are able to exploit the path variable for manipulations. Remote attackers are able to inject own script codes to the client-side requested vulnerable web-application parameters. The attack vector of the vulnerability is non-persistent and the request method to inject/execute is POST/GET. The vulnerabilities are classic client-side cross site scripting vulnerabilities. Successful exploitation of the vulnerability results in session hijacking, non-persistent phishing attacks, non-persistent external redirects to malicious source and non-persistent manipulation of affected or connected application modules. Request Method(s): [+] GET Vulnerable Module(s): [+] list [+] download Vulnerable Parameter(s): [+] path Proof of Concept: ================= The cross site scripting vulnerability can be exploited by remote attackers without privileged user account and with low user interaction. For security demonstration or to reproduce the cross site scripting vulnerability follow the provided information and steps below to continue. PoC: Payload >"test PoC: Vulnerable Source HTTP Error 404

HTTP Error 404: "